Mer

Geoserver: FAIL -kontekstbanen starter ikke


Jeg har manipulert Geoserver en stund uten problemer.

I dag, når jeg starter Apache Tomcat, starter ikke Geoserver.

Jeg får denne feilmeldingen:

"FAIL - Søknad på kontekststi /Geoserver kunne ikke startes"

Jeg vet ikke hva som synes å være problemet. Vennligst hjelp meg med dette problemet ᐧ


@ImaneKtb finner du i .../geoserver/gwc/yourlayersmappen. Bare slett en av dere "din spillermappe". Hele banen til geoserver det avhenger av installasjonstypen din (Windows, Linux, Geoserver installatør, Grenseløs installatør etc.) Det hjalp meg, men det betyr ikke at det vil hjelpe i ditt tilfelle. Feilen ser ut som en generisk feil. Men uansett, håper det hjelper.


Jeg opplevde også en slik situasjon.

Tilsynelatende var alt "ok" med min Tomcat -installasjon, og jeg syntes også å plassere den.krigfilen ordentlig (da jeg kunne se at mappen ble opprettet på/webappskatalog).

Det som hjalp meg med å finne svaret var å sjekk Tomcat -loggene; du kan se dem i/tomcat/logskatalogen (spesieltcatalina.outfil).

Problemet mitt var at versjonen av Geoserver jeg brukte (2.13.0) krever Java 8 for å kjøre, og jeg brukte Java 7. Jeg foreslår deg sjekk loggene dine, og også kravene til din Geoserver -versjon. Å endre konfigurasjonen min for å bruke Java 8 løste problemet, og jeg kunne starte og få tilgang til nettjenesten min.