Mer

Installering av PostGIS gir feil: kunne du ikke finne libpq?


Etter å ha gitt kommandoen./konfigurasjon, det viser at:

pQserverversion i -lpq ikke funnet. configure: error: kunne ikke finne libpq.

Hva betyr det?

Jeg installerer PostGIS 1.5 ved hjelp av Red hat Linux (32 bit) versjon 5.3. PostgreSQL versjon 8.3.


Jeg er enig med Craig. Redhat -versjonen din er veldig gammel. Uansett, problemet er at du trenger pakken libpq-dev installert.

yum installer libpq-dev

' FEIL: kunne ikke få tilgang til filen & ldquo $ libdir/postgis-2.5 & rdquo: Ingen slik fil eller katalog ' [stengt]

Vil du forbedre dette spørsmålet? Oppdater spørsmålet slik at det er på emnet for databaseadministratorer Stack Exchange.

Å håndtere PostGIS har vært et mareritt fra dag én. Hver eneste gang jeg må berøre det på noen måte, eller oppdatere PostgreSQL, blir det til et ødelagt rot. Den eneste grunnen til at jeg bruker den er fordi jeg må kunne bruke "geografi" -kolonner og noen få "st_" -funksjoner.

Inntil for noen dager siden hadde jeg EnterpriseDBs PostgreSQL 11.5 installert på Windows 10. PostGIS var installert. Deretter installerte jeg EnterpriseDBs PostgreSQL 11.7 for å oppdatere den. Nå mistet det liksom PostGIS, så jeg installerte det på nytt også. Alt må gjøres manuelt av en eller annen grunn.

Nå gir hver spørring relatert til PostGIS denne feilen:

Jeg vet ikke hvorfor det står 2.5 da jeg installerte postgis-bundle-pg11x64-setup-3.0.1-2.exe.

Dette fungerer ikke i det hele tatt (eksisterer ikke):

Jeg har seriøst brukt så mye av livet mitt bare på å kjempe med PostGIS at jeg virkelig hater det, og skulle ønske jeg kunne bli kvitt det for alltid. Eller at de i det minste kunne få til handling og integrere det riktig i PostgreSQL, slik at det ikke fører til alle disse dumme problemene hele tiden. Jeg forstår ikke hvorfor det må kreve så mye manuelt arbeid og fikling. Hvorfor kan den ikke bare gjøre disse trinnene automatisk?


Texmaker gir en feil: kunne ikke starte kommandoen

Ta en titt på dette svaret Kan ikke kompilere TeXmaker 4.0.2 med MiKTeX 2.9 og bruk det relaterte trikset basert på din posisjon/feil, forutsatt at MiKTeX er riktig installert og test installasjonen ved å følge trinnene

  • Når du kjører cmd fra Start -menysøk, åpnes den på C: Users brukernavn & gt
  • skriv cd Desktop for å få C: Users brukernavn Desktop & gt

skriv nå pdflatex sample2e for å få sample2e.pdf, så er det bekreftet at installasjonen fungerer som den skal og banen er ok.

Skriv også på C: Users brukernavn Desktop & gt Path for å se om det er MiKTeX bin som C: Program Files (x86) MiKTeX 2.9 bin avhengig av hvor den ble installert på 32 bit eller 64 bit OS og MiKTeX Distro

Siste TeXmaker er 4.0.3 utgitt 29. juli 2013.

I verste fall Alternativer -> Innstillingsfil -> Tilbakestill innstillinger, og husk å lagre innstillingsfilen et sted for sikkerhetskopiering. Start TeXmaker på nytt slik at TeXmaker automatisk konfigurerer latex -dvips -kjørbare filer


PostgreSQL Stack Builder Installasjonsproxyinnstilling på Windows

Jeg har lastet ned og installert PostgreSQL 9.3 (64 bit) på en utviklermaskin som kjører Windows 8.1 (64 bit). Denne utviklermaskinen krever bruk av en proxy -server for å få tilgang til verter som er eksterne til LAN.

StackBuilder 3.1.1 Veiviser / installatør henter proxy -innstillingene fra IE, og de ser ut til å være riktige, men når du klikker på "Neste" -knappen, får jeg en "Stack Builder Error" -dialog som angir:

Jeg har lykkes med å laste ned applikasjonslisten ved hjelp av IE og Chrome med de samme proxy -innstillingene som installasjonsprogrammet opprinnelig hentet fra IE.

Andre ting jeg har prøvd:

  • Forhåndsventer proxy-serverens vertsnavn med protokollen 'http: //'
  • Brukte proxy -serverens IP -adresse i stedet for vertsnavnet
  • Fjernet proxy -innstillingene helt

I de to første tilfellene reagerer installasjonsprogrammet nesten umiddelbart med feilmeldingen ovenfor. I det siste er det omtrent en 5 sekunders forsinkelse før den svarer med feilmeldingen ovenfor.

Et lignende problem ser ut til å være dokumentert som en feil på PostgreSQL bug tracker, men det har ikke vært noe svar på den første rapporten.

Er det noen som kjenner til dette problemet, og i så fall hvilke arbeidsomgivelser har vist seg å være effektive i å bruke installasjonsprogrammet for Stack Builder?


Mdhntd

Hvor umulig ville en selvlysende plantebasert livsform være?

Hvorfor bør man være forsiktig når man lukker en kapasitiv krets?

Kan jeg sende inn en papir -datavitenskapskonferanse med et alias hvis bruk av mitt virkelige navn kan forårsake juridiske problemer i mitt opprinnelige land

Vegetarretter på russiske tog (europeisk del)

Spiller en rask, men stille Alberti -bass

vanskelig stram fingring

Er det en kommersiell væske med brytningsindeks større enn n = 2?

Indirekte tale - bryte reglene for det

Har gjort flere feil i løpet av min doktorgrad. Kan ikke annet enn å føle harme. Kan jeg få noen råd om hvordan jeg går videre?

Hva skjedde etter slutten av Truman Show?

iPad eller iPhone lades ikke før den er låst opp?

Er det pålitelige, formelle måter å lage akkorder på gitaren?

Hvordan bruke source_location i en variabel malfunksjon?

Radix2 Fast Fourier Transform implementert i C ++

Kan jeg sjekke et lite utvalg bools på en gang?

Lider bankenes lønnsomhet virkelig under lave renter

Starship uten datamaskiner?

Si noe til en utenlandsk kollega som bruker "dere mennesker"

Kan andre tjene penger på prosjektet mitt med GPLv3?

Hvordan oppdage en mislykket AES256 -dekryptering programmatisk?

Bygg en mengde mistenkelig glade lenny -ansikter (͡ ° ͜ ʖ ͡ °)

Hadde Wernher von Braun virkelig en "Saturn V malt som V2"?

Kontroller diskbruk av filer som returneres med mellomrom

Feil ved installering av PostGIS -utvidelsen gjennom PostgreSQL 11

Aktiver PostGIS-utvidelser Windows lokalt (ikke-admin) med Anaconda PostgreSQLRunning Opprett utvidelse postgis gir ERROR ikke kunne åpne filtypen for utvidelse? PostGIS-utvidelsen er ikke tilgjengelig i Postgresql-listen Hvordan installere postgis-utvidelsen ved hjelp av en eksisterende versjon på postgresql på OSX 10.9.4 Feil i installering av PostGIS 1.5? PostgreSQL - PostGIS -tilkoblingsfeil Feil for å lage postgis -utvidelse Installere PgPointCloud -utvidelse for PostgreSQL på Ubuntu Bionic

Jeg får følgende problemer mens jeg installerer PostGIS -utvidelsen.

Husk å inkludere feilmeldingen i tekstens brødtekst. Dette gjør den lesbar på alle enheter og tillater fritekstsøk.

Hei Mustak - Jeg kan ikke fortelle om du har vært på PostGis -nettstedet og lastet ned installasjonsprogrammet eller zip -filene som postgres må bruke for dette. Forutsatt at du har gjort det, er mitt neste gjetning kanskje en versjon som ikke stemmer overens? Hvis du tar tak i zip -filen, har de en innebygd readme som instruerer deg om hvilke postgis -elementer som går i postgres -installasjonen din, noe som kan være en måte å få mer informasjon om hva som har gått galt.

Hei Atcrank, faktisk gjorde jeg det du sier. det samme gjorde jeg på en annen datamaskin, men fungerte bra. Det viser problem i systemet mitt

Jeg får følgende problemer mens jeg installerer PostGIS -utvidelsen.

Husk å inkludere feilmeldingen i tekstens brødtekst som tekst. Dette gjør den lesbar på alle enheter og tillater fritekstsøk.

Hei Mustak - Jeg kan ikke fortelle om du har vært på PostGis -nettstedet og lastet ned installasjonsprogrammet eller zip -filene som postgres må bruke for dette. Forutsatt at du har gjort det, er mitt neste gjetning kanskje en versjon som ikke stemmer overens? Hvis du tar tak i zip -filen, har de en innebygd readme som instruerer deg om hvilke postgis -elementer som går hvor i postgres -installasjonen din, noe som kan være en måte å få mer informasjon om hva som har gått galt.

Hei Atcrank, faktisk gjorde jeg det du sier. det samme gjorde jeg på en annen datamaskin, men fungerte bra. Det viser problem i systemet mitt

Jeg får følgende problemer mens jeg installerer PostGIS -utvidelsen.

Jeg får følgende problemer mens jeg installerer PostGIS -utvidelsen.

Husk å inkludere feilmeldingen i tekstens brødtekst. Dette gjør den lesbar på alle enheter og tillater fritekstsøk.

Hei Mustak - Jeg kan ikke fortelle om du har vært på PostGis -nettstedet og lastet ned installasjonsprogrammet eller zip -filene som postgres må bruke for dette. Forutsatt at du har gjort det, er mitt neste gjetning kanskje en versjon som ikke stemmer overens? Hvis du tar tak i zip -filen, har de en innebygd readme som instruerer deg om hvilke postgis -elementer som går i postgres -installasjonen din, noe som kan være en måte å få mer informasjon om hva som har gått galt.

Hei Atcrank, faktisk gjorde jeg det du sier. det samme gjorde jeg på en annen datamaskin, men fungerte bra. Det viser problem i systemet mitt

Husk å inkludere feilmeldingen i tekstens brødtekst. Dette gjør den lesbar på alle enheter og tillater fritekstsøk.

Hei Mustak - Jeg kan ikke fortelle om du har vært på PostGis -nettstedet og lastet ned installasjonsprogrammet eller zip -filene som postgres må bruke for dette. Forutsatt at du har gjort det, er mitt neste gjetning kanskje en versjon som ikke stemmer overens? Hvis du tar tak i zip -filen, har de en innebygd readme som instruerer deg om hvilke postgis -elementer som går i postgres -installasjonen din, noe som kan være en måte å få mer informasjon om hva som har gått galt.

Hei Atcrank, faktisk gjorde jeg det du sier. det samme gjorde jeg på en annen datamaskin, men fungerte bra. Det viser problem i systemet mitt

Husk å inkludere feilmeldingen i tekstens brødtekst som tekst. Dette gjør den lesbar på alle enheter og tillater fritekstsøk.

Husk å inkludere feilmeldingen i tekstens brødtekst. Dette gjør den lesbar på alle enheter og tillater fritekstsøk.

Hei Mustak - Jeg kan ikke fortelle om du har vært på PostGis -nettstedet og lastet ned installasjonsprogrammet eller zip -filene som postgres må bruke for dette. Forutsatt at du har gjort det, er mitt neste gjetning kanskje en versjon som ikke stemmer overens? Hvis du tar tak i zip -filen, har de en innebygd readme som instruerer deg om hvilke postgis -elementer som går i postgres -installasjonen din, noe som kan være en måte å få mer informasjon om hva som har gått galt.

Hei Mustak - Jeg kan ikke fortelle om du har vært på PostGis -nettstedet og lastet ned installasjonsprogrammet eller zip -filene som postgres må bruke for dette. Forutsatt at du har gjort det, er mitt neste gjetning kanskje en versjon som ikke stemmer overens? Hvis du tar tak i zip -filen, har de en innebygd readme som instruerer deg om hvilke postgis -elementer som går i postgres -installasjonen din, noe som kan være en måte å få mer informasjon om hva som har gått galt.

Hei Atcrank, faktisk gjorde jeg det du sier. det samme gjorde jeg på en annen datamaskin, men fungerte bra. Det viser problem i systemet mitt

Hei Atcrank, faktisk gjorde jeg det du sier. det samme gjorde jeg på en annen datamaskin, men fungerte bra. Det viser problem i systemet mitt


Egendefinert plassering for postgis -utvidelsen .kontrollfil [lukket]

Vil du forbedre dette spørsmålet? Oppdater spørsmålet slik at det er et tema for databaseadministratorer Stack Exchange.

Jeg prøver å installere postgis -utvidelsen på databasen min, som ligger på en webvertstjeneste. Problemet er at kontrollfilene ser ut til å måtte finnes i /package/host/localhost/postgresq-9.3.2-1. Jeg bruker et vertsfirma der alt vi kan få tilgang til er det som er i våre respektive hjem/ mapper. Postgres -kjørbare filer finnes i rotkatalogene som vi ikke får tilgang til.

Jeg har installert PostGIS-binariene, men nå når jeg prøver å lage utvidelsen med CREATE EXTENSION postgis, får jeg feilen FEIL: kunne ikke åpne filens fil/pakke/host/localhost/postgresql-9.3.2-1/deling /utvidelse/postgis.control. Jeg kan ikke skrive noe til denne katalogen siden den bare er ment å lagre kjørbare filer for alle å få tilgang til via noen skript hostingleverandøren slik den er konfigurert.

Kan jeg få denne .control -filen til å være et annet sted i stedet? Eller er jeg bare helt flaks?


Generelt oppsett for Ubuntu

Denne prosedyren støtter også WSL - Windows Subsystem for Linux. Dette betyr at en Windows 10 64-biters PC kan brukes til å utføre installasjonen etter at WSL er konfigurert.

Oppdater Ubuntu

Sørg for at Ubuntu-systemet ditt er fullt oppdatert:

Forrige kommando returnerer Ubuntu -versjonen.

Hvis du på et helt nytt system også vil gjøre sudo apt-get dist-upgrade & amp & amp sudo shutdown -r nå.

Installer viktige verktøy

Sjekk forutsetningene foreslått av openstreetmap-carto.

For de påfølgende installasjonstrinnene antar vi at cd -en er standard for hjemmekatalogen din.

Konfigurer et bytte

Importere og administrere kartdata tar mye RAM, og det er generelt behov for bytte.

For å kontrollere om en byttepartisjon allerede er konfigurert på systemet ditt, bruk en av følgende to kommandoer:

Rapporterer oversikten over byttebruk (ingen utgang betyr manglende bytte):

Vis mengden ledig og brukt minne i systemet (sjekk linjen som angir Bytte):

Hvis du ikke har en aktiv byttepartisjon, spesielt hvis det fysiske minnet er lite, bør du legge til en byttefil. Først bruker vi kommandoen fallocate for å lage en fil. Lag for eksempel en fil med navnet byttefil med 2G kapasitet i rotfilsystemet:


Generelt oppsett for Ubuntu

Denne prosedyren støtter også WSL - Windows Subsystem for Linux. Dette betyr at en Windows 10 64-biters PC kan brukes til å utføre installasjonen etter at WSL er konfigurert.

Oppdater Ubuntu

Sørg for at Ubuntu-systemet ditt er fullt oppdatert:

Forrige kommando returnerer Ubuntu -versjonen.

Hvis du på et helt nytt system også vil gjøre sudo apt-get dist-upgrade & amp & amp sudo shutdown -r nå.

Installer viktige verktøy

Sjekk forutsetningene foreslått av openstreetmap-carto.

For de påfølgende installasjonstrinnene antar vi at cd -en er standard for hjemmekatalogen din.

Konfigurer et bytte

Importere og administrere kartdata tar mye RAM, og det er generelt behov for bytte.

For å kontrollere om en byttepartisjon allerede er konfigurert på systemet ditt, bruk en av følgende to kommandoer:

Rapporterer oversikten over byttebruk (ingen utgang betyr manglende bytte):

Vis mengden ledig og brukt minne i systemet (sjekk linjen som angir Bytte):

Hvis du ikke har en aktiv byttepartisjon, spesielt hvis det fysiske minnet er lite, bør du legge til en byttefil. Først bruker vi kommandoen fallocate for å lage en fil. Lag for eksempel en fil med navnet byttefil med 2G kapasitet i rotfilsystemet:


Feil ved installasjon av & ldquovanilla & rdquo TexLive på Ubuntu 14.04

Jeg har lest alle svarene på "Hvordan installere" vanilje "Tex Live på Debian eller Ubuntu?" og brukte scottkostys skript for å gjøre det. Jeg får en feil på slutten av installasjonsprosessen:

Det samme skjedde da jeg prøvde manuell installasjon: når jeg skulle endre PATH -variabelen og skrive hvilken tex kommandolinjen ga/usr/bin/tex i stedet for/opt/texbin/tex, noe som for meg angav at symbolsk lenke ikke ble skapt riktig. Men siden jeg har ganske nær null erfaring på Ubuntu -kommandolinjen (eller kommandolinjen for den saks skyld) og nettopp begynte å bruke -forelsket i- TeX for å skrive inn dokumentene mine, selv om jeg spør her. Hva er galt? Hvis det er nødvendig, hva mer informasjon kan jeg gi for å spesifisere problemet mitt i beste fall?

Vet ikke om det betyr noe eller ikke, men før jeg prøvde å installere vanilje hadde jeg TexLive installert via apt-get texlive. Deretter, etter en kronologisk rekkefølge: Jeg fjernet TexLive etter Dette, prøvde å installere vanilje ved hjelp av Sileks metode (fungerte ikke, som sagt før), fjernet igjen, kom til slutt til skriptet ved å anta at jeg gjorde noe galt, kom til det samme problemet, der jeg fortsatt sitter fast.


Jeg ville foretrukket å legge dette til som en kommentar, men med mindre du faktisk trenger libmount for noe, er det mye lettere å bare deaktivere det ved å passere --enable-libmount = no to configure.

du trenger biblioteket med overskrifter. pakkenavn som slutter på -dev inneholder overskrifter

dette vil gi deg de manglende overskriftene. for å bekrefte problemet

Du må kryss-kompilere libmount og gjøre den tilgjengelig for kryss-kompilatoren (og antagelig cross-pkg-config).


5 Svar 5

Du kan også prøve følgende pakke: DMwR.

Det mislyktes i tilfellet med 3 NN, og ga 'Feil i knnImputation (x, k = 3): Ikke tilstrekkelige komplette saker for å beregne naboer.'

Du kan teste for tilstrekkelige observasjoner ved å bruke complete.cases (x), der verdien må være minst k.

En måte å overvinne dette problemet på er å slappe av kravene dine (dvs. mindre ufullstendige rader), med 1) å øke NA -terskelen, eller alternativt 2) å øke antall observasjoner.

her er et eksempel på det andre.

Minst k = 3 komplette rader er tilfredsstilt, og dermed kan det beregnes for k = 3.


Se videoen: Getting started with PostGIS - Installation (Oktober 2021).